V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
monster33
V2EX  ›  程序员

生产环境选择 debian10 还是 debian11

  •  
  •   monster33 · 2022-04-02 13:30:17 +08:00 · 7347 次点击
    这是一个创建于 783 天前的主题,其中的信息可能已经有所发展或是发生改变。

    只考虑 debian 系统的话,这两个里面选哪个? 从稳定性和性能方面来说。好像 debian11 不是特别大的改动。

    https://www.debian.org/releases/stable/s390x/release-notes/ch-whats-new.zh-cn.html

    27 条回复    2022-04-03 04:56:18 +08:00
    ysicing
        1
    ysicing  
       2022-04-02 13:39:10 +08:00
    新节点已经上了 debian11 了,存量的还是 debian10
    knightdf
        2
    knightdf  
       2022-04-02 13:41:43 +08:00
    想都不用想啊,用新不用旧,前提是测试好
    monster33
        3
    monster33  
    OP
       2022-04-02 13:47:15 +08:00
    @ysicing debian11 没啥 bug 吧?
    Tumblr
        4
    Tumblr  
       2022-04-02 13:49:49 +08:00
    虽说用新不用旧,但是生产环境一般习惯于大版本上比最新的降一个版本,或者新版本出来等一年。
    不过,如果自己生产环境的生态比较成熟的话,还是建议 11 。

    我个人是冒险主义的,测试环境 preview 就敢上,生产环境出来半年也敢用!
    iBugOne
        5
    iBugOne  
       2022-04-02 13:53:57 +08:00 via Android
    @Tumblr 冒险主义比较敢用 Arch Linux ,另外据我所知清华大学镜像站在 Debian 11 刚出来没几天就升上去了
    Tumblr
        6
    Tumblr  
       2022-04-02 13:59:05 +08:00
    @iBugOne #5 我是 Windows 派的,生产环境里 Windows Server 2022 已经用上了。。。垃圾微软!(只为政治正确,WS2022 很爽!)
    y0bcn
        7
    y0bcn  
       2022-04-02 14:00:19 +08:00
    我们上的是 debian11 ,没啥问题
    wu67
        8
    wu67  
       2022-04-02 14:26:25 +08:00
    跟着各 vps 厂商走就行了. 人家这么大一厂家都敢上, 基本都没大毛病.
    laozhoubuluo
        9
    laozhoubuluo  
       2022-04-02 15:09:44 +08:00
    原则上还是要上 Debian 11 的,毕竟根据官方文档 https://wiki.debian.org/DebianReleases ,Debian 10 距离结束主流支持( 2022.8 )不远了,虽然还有 2 年的 LTS 以及后续由第三方提供的 ELTS 但是还是建议直接上新版本。

    另外手册建议看对应架构的,如 AMD64 为 https://www.debian.org/releases/stable/amd64/release-notes/ch-whats-new.zh-cn.html
    exiledkingcc
        10
    exiledkingcc  
       2022-04-02 15:17:23 +08:00
    debian 本身就够旧的了,还要用旧版本???
    cco
        11
    cco  
       2022-04-02 15:41:53 +08:00
    用新不用旧,一旦用起来除非有什么特别严重的问题,不然很少升级,日常修补丁就行了。
    ruixue
        12
    ruixue  
       2022-04-02 16:49:51 +08:00
    debian 的更新策略已经很保守了,生产环境选择 debian stable ,自己折腾直接上 debian testing 都行
    geekvcn
        13
    geekvcn  
       2022-04-02 17:05:07 +08:00
    Debian11
    getadoggie
        14
    getadoggie  
       2022-04-02 17:23:48 +08:00
    上次编译 aria2,本来想着新嘛,用 debian11 的镜像编译的,按标准流程走,报各种错误,库找不到,后来没办法换成了 debian10,发现流畅的很,没有报错,又多试了几次,发现是 debian11 的问题,可能是安装的软件包修改了什么。
    adoal
        15
    adoal  
       2022-04-02 17:29:36 +08:00 via iPhone
    Debian 11 已经到第三个 point release 了,如果不是为了用依赖老库的软件,新开的节点没必要坚守 10
    z1645444
        16
    z1645444  
       2022-04-02 17:31:00 +08:00 via Android
    Debian 是保守中的保守,stable 就直接用最新吧,其实比较推荐用 testing ,如果是 ubuntu 那才可能建议用最新版本的上一个大版本
    tyzrj766
        17
    tyzrj766  
       2022-04-02 17:33:05 +08:00
    用哪个都没啥感觉,11 就可以
    bao3
        18
    bao3  
       2022-04-02 17:37:02 +08:00
    重要且不会更动的应用,还是用 debian10
    新的项目,还在迭代的,都用 debian 11 。
    以前我也喜欢追新,后来才明白,够用即可,太新了增加自己的烦恼
    Cielsky
        19
    Cielsky  
       2022-04-02 17:43:10 +08:00
    debian 的更新策略还不保守啊,你还想在此基础上再保守一下吗?
    wzw
        20
    wzw  
       2022-04-02 17:43:15 +08:00 via iPhone
    以前用 debian ,现在用 Ubuntu 20.04 ,少一些选择
    Huelse
        21
    Huelse  
       2022-04-02 18:01:00 +08:00
    debian 妥妥的保守派,为了兼容老旧包做了一堆妥协
    cmdOptionKana
        22
    cmdOptionKana  
       2022-04-02 18:08:12 +08:00
    认准最新的 stable 版本就行,debian 的 stable 是真 stable ,里面的软件本身已经是很旧的版本了。
    starcraft
        23
    starcraft  
       2022-04-02 19:24:30 +08:00
    前两天刚把手上一台自己的机子换成 11 ,和我自己笔记本里 arch 比简直是个老古董。
    findex
        24
    findex  
       2022-04-02 19:29:21 +08:00
    debian 的 stable 版本比其他发行版的 LTS 要稳定多了,即便是别家 LTS 不支持了,debian 的 stable 还会更新安全补丁。

    已经将某些服务器 debian10 升级到 debian11 了,升级没有啥痛点。

    debian 的 testing 都比某些 LTS 稳。

    @starcraft archlinux 比较激进。用了好多年,时间一长升级,一滚就挂。目前 archlinux 活在 debian 的虚拟机里面。
    Akitora
        25
    Akitora  
       2022-04-02 20:02:28 +08:00
    升级了 11 感觉没差
    abcysn
        26
    abcysn  
       2022-04-02 22:24:44 +08:00
    我的一个 go 程序有 cgo ,引用第三方库没办法绕开,用 debian 11 编译速度慢的出奇,要十几分钟,debian 10 稍微快一点,debian 9 快很多,一两分钟。不过可能不是 debian 11 的问题,或许是 gcc 版本越高某方面的性能越差。
    msg7086
        27
    msg7086  
       2022-04-03 04:56:18 +08:00 via Android
    你软件支持什么就用什么。稳定性和性能一般不是选择版本的依据,abi api 兼容性才是。如果不挑 abi api 就,那无脑选新版就是了。

    比如以前我司的一套软件只能跑 14.04 ,你想换 16.04 ,不好意思,跑不起来。这种时候才会去考虑用旧版。这和你说的稳定性和性能没什么关系的。
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   2467 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 27ms · UTC 01:49 · PVG 09:49 · LAX 18:49 · JFK 21:49
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.