V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
nodejsexpress
V2EX  ›  Windows

windows11 的 WSL 和 Vmware 是不是不兼容

  •  
  •   nodejsexpress · 87 天前 · 2669 次点击
    这是一个创建于 87 天前的主题,其中的信息可能已经有所发展或是发生改变。

    安装 vmare player 的时候提示要关闭 hyper-v , 网上搜了下资料,说要把 windows 自带的虚拟化禁用了,才能用 vmware 的虚拟化。

    有懂的大师提示下么。

    24 条回复    2024-01-16 10:56:28 +08:00
    Tanix2
        1
    Tanix2  
       87 天前
    我搜的是说,有和 hyper-v 兼容的 VMware 版本
    ysc3839
        2
    ysc3839  
       87 天前 via Android
    你用的是什么版本的 VMware?
    AoEiuV020JP
        3
    AoEiuV020JP  
       87 天前
    巧了我刚也在搜这个,
    新版 vm 是有专门做过兼容的,
    只要新版 win+新版 vm 再开关几个设置就可以,
    还没尝试,
    flyqie
        4
    flyqie  
       87 天前 via Android
    说明你用的是 wsl2 。。。

    wsl1 是不需要虚拟化支持的,我现在 win10+vmware 无任何问题。
    iFengJQ
        5
    iFengJQ  
       87 天前 via Android
    @AoEiuV020JP 去掉处理器虚拟化后,安装 linux 会存在音频卡顿爆音的问题。
    iamwin
        6
    iamwin  
       87 天前
    win10 装 wsl2 直接要求你去 bios 里面打开 cpu 虚拟化,也是兼容 vmware 的
    duanxianze
        7
    duanxianze  
       87 天前
    vmware 要看版本,也有基于 hyper-v 的版本
    smartruid
        8
    smartruid  
       87 天前
    早就兼容啦,这俩我都在用
    nodejsexpress
        9
    nodejsexpress  
    OP
       87 天前
    @AoEiuV020JP 去掉后卡的要命。。
    xfn
        10
    xfn  
       87 天前
    vmware 在和 hyper-v 并存的情况下,本质上用的就是 hyper-v 的 hypervisor ,vmware 实际上就退化成了一个壳
    cc666
        11
    cc666  
       87 天前
    说明你安装的是 16 版本以下的 Vmware 或者没有勾选 WHP
    这种生产力工具 Vmware 肯定早就支持了
    tairan2006
        12
    tairan2006  
       87 天前
    不如直接用 hyper-v
    cy18
        13
    cy18  
       87 天前
    控制面表/Windows 功能里面有个“虚拟机平台”打开应该就可以了。
    sayakafs
        14
    sayakafs  
       87 天前
    兼容 但是虚拟机里面再起虚拟机就不行了
    chenliangngng
        15
    chenliangngng  
       87 天前
    建议不要用 wsl
    Tiande
        16
    Tiande  
       87 天前
    折腾过很久最后还是用 VMware 跑虚拟机了。hyper-v 属于是大坑...
    leconio
        17
    leconio  
       87 天前 via iPhone
    我记得开了内核隔离后好像本体都是跑在 hyperv 里面的,好像很难关掉。
    imzcg2
        18
    imzcg2  
       87 天前
    我就是 wsl2 vbox vmware 三个都用的 没毛病
    junmoxiao
        19
    junmoxiao  
       86 天前
    不建议一起用,vm16 之后可以一起用,但是 vm 的性能会严重降低
    oxromantic
        20
    oxromantic  
       86 天前
    hyperv 是当年干不过 vmware 才被微软收购的,被这种大公司收购后的产品,基本都是吃老本了
    leaflxh
        21
    leaflxh  
       86 天前
    记得是新版本有兼容,但需要些设置,要改 windows 引导的某些参数
    neoblackcap
        22
    neoblackcap  
       86 天前
    @oxromantic Azure 的根基,不可能不维护不更新的
    chapiom
        23
    chapiom  
       44 天前 via iPhone
    我这边 hyperv 连不了网,怎么配置网卡都没用
    nodejsexpress
        24
    nodejsexpress  
    OP
       37 天前
    @chapiom 网上找的教程,折腾下就可以了。
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   我们的愿景   ·   实用小工具   ·   935 人在线   最高记录 6543   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 28ms · UTC 20:58 · PVG 04:58 · LAX 12:58 · JFK 15:58
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.