首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  topthink  ›  全部回复第 1 页 / 共 5 页
回复总数  87
1  2  3  4  5  
@wo642436249 5.1 版本的 swoole 扩展是不支持协程的,6.0 版本才支持 不过由于 6.0 版本尚未正式发布 所以建议观望先
@wo642436249 你自己都没尝试 怎么就断定完全不兼容了 服了 U
170 天前
回复了 topthink 创建的主题 推广 「ThinkPHP 开发者周刊」第 35 期——女皇报告
@Livid https://www.v2ex.com/t/570228 这个也算是推广么? ThinkPHP 在 V2 这么招黑么?
170 天前
回复了 topthink 创建的主题 推广 「ThinkPHP 开发者周刊」第 35 期——女皇报告
@Livid 作为一个 PHP 开发者周刊 怎么就被认定为推广软文了?请问我推广什么了?
@wo642436249 怎么叫完全不兼容
@wo642436249 从 5.1 版本开始就引入对 swoole 的支持 6.0 版本更是对 swoole 的支持完善(包括对协程的支持),但 ThinkPHP 毕竟不是一个基于 Swoole 的框架 这点和所有基于 swoole 开发的框架不同,优势不同,服务的群体也不同,所以对 Swoole 的支持都是通过扩展 而非核心内置
@Tierney 不要有什么误会,框架不能总是背着历史包袱前行,太多的兼容只会让框架裹足不前,而且底层重构不代表不能升级,每次官方都会给出升级指导
@baiban 5.0 和 5.1 上有一些不兼容更新主要是安全更新导致的 一般不太可能变动语法,而且新版之所以跨版本发布也是考虑到升级问题
@ThankYou 不要安装 3.0 版本 5.1 只能安装 2.0 版本
@dvaknheo 放了你又能干嘛?又不是 web 部署目录 你去看下 symfony 的 console
@passerbytiny 你可能有所误会 其实本意是想说只支持 composer 安装而已 create-project 只是新手安装方便而已
@wo642436249 你可以具体反馈下不适用的原因 或者给我们提建议
@815979670 TP6 是从之前的 5.2 版本变更而来,就是因为底层架构调整较大,无法满足 5.1 版本的无缝升级,因此更名的
@JaguarJack 在拥抱 composer 这件事上 TP 的策略是循序渐进的 因为太多用户卡在这个环节,经过两个版本的过渡,6.0 版本才强制使用 composer 安装( 5.0 和 5.1 是支持 composer 安装,并且 5.1 版本开始不提供官方下载)
@dvaknheo 5.0 基本不更新了 5.1 目前是稳定版本而且是 LTS 虽然 3.2 的用户群还有很多,但官方已经无法支持了 6.0 是目前主要更新迭代版本
@ritaswc 感谢支持
@baiban 如果不更新,就有人会说官方不思进取,更新频繁了又会有人抱怨,所以走自己的路,让别人说去吧!选择合适自己的版本最重要~
@GTim 因为 traits 目录是计划增加更多的 trait 的
@ritaswc 首先感谢建议
1 控制器是否需要继承 取决于自身 实例没必要继承
2 数据库怎么配置自己来决定 那个只是默认配置
3 目录结构对于之前的 5.1 来说并没有大改 是不过原来的多模块设计变成多应用设计而已

恨铁不成钢能理解 但 TP 这么多年还能保持更新 而且在追随主流现代化框架设计思想,原有用户都一直在抱怨每次升级变化太大,所以需要从 TP 用户群成长性考虑 ,也没有什么特别的 PHP 新特性需要引入了 其它的功能支持都是纳入扩展的规范
242 天前
回复了 topthink 创建的主题 推广 ThinkPHP 发布 5.2RC1 版本——诸多查询改进
@hero2040407 从 5.1 版本开始对 swoole 的支持和改进就一直纳入重要考虑,现 5.2 已经正式变更为 6.0 版本(下一个大版本),对 swoole 以及协程的支持更加完善
think-swoole 支持 session 干嘛非要用$_SESSION 呢?
给开源项目多做贡献(无论是核心 PR 还是扩展开发),然后在参与的过程中会逼得自己去学习
@ifu25 支持的
1  2  3  4  5  
关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1029 人在线   最高记录 5043   ·     Select Language
创意工作者们的社区
World is powered by solitude
VERSION: 3.9.8.3 · 22ms · UTC 22:49 · PVG 06:49 · LAX 14:49 · JFK 17:49
♥ Do have faith in what you're doing.