首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
The Go Programming Language
http://golang.org/
Go Playground
Go Projects
Revel Web Framework
beego
Coding
V2EX  ›  Go

go mod 怎么导入 go-sqlite3 啊??

  •  
  •   dafsic · 32 天前 · 1524 次点击
    这是一个创建于 32 天前的主题,其中的信息可能已经有所发展或是发生改变。

    import ( "database/sql" _ "github.com/mattn/go-sqlite3" )

    以前是上面这样的,可以正常用,切到 go mod 模式后,执行 go mod tidy 出现下面提示,那么我 improt 要怎么写才能正常?

    github.com/mattn/go-sqlite3: module github.com/mattn/[email protected] found (v2.0.0+incompatible), but does not contain package github.com/mattn/go-sqlite3

    4 回复  |  直到 2019-11-20 00:33:03 +08:00
        1
    dafsic   31 天前
    解决方式:go get -v -u github.com/mattn/[email protected] ( go1.13.4 )
        2
    guonaihong   31 天前
    在 go.mod 里面加上
    require github.com/mattn/go-sqlite3 v1.10.0
        3
    tutuyuen   30 天前
    2L 正解 修改 go.mod
    `github.com/mattn/go-sqlite3 v2.0.0+incompatible // indirect` --> `github.com/mattn/go-sqlite3 v1.10.0`
        4
    renhua   24 天前 via Android
    恰好遇到这个问题
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   891 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 26ms · UTC 21:08 · PVG 05:08 · LAX 13:08 · JFK 16:08
    ♥ Do have faith in what you're doing.