V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
DukeAnn
V2EX  ›  问与答

cnpm install 不读锁文件?直接读 package.json?

  •  
  •   DukeAnn · 2018-04-23 11:24:25 +08:00 · 3912 次点击
    这是一个创建于 1869 天前的主题,其中的信息可能已经有所发展或是发生改变。

    项目里面用了 iview ,因为版本的升级会导致 table 样式变得跟原来版本不一致,最后一个是配的版本是 2.12.0

    package.json 上写的版本是 ^2.7.2

    package-lock.json 上写的版本是 2.7.4

    使用 npm install 拉下来的版本就是 2.7.4

    但是使用 cnpm install 拉下来的就是 ^2.7.2 限制的最新版, 2.13

    从上面的结果来看是不是 cnpm 没有读取锁文件直接自己全部根据 package.json 的版本限制进行拉取了。

    有没有大神解答一下是不是这样呢?

    4 条回复    2018-04-23 12:37:06 +08:00
    Wolfpancake
        1
    Wolfpancake  
       2018-04-23 11:53:38 +08:00
    是的 cnpm 不支持且似乎不打算支持 lock

    [https://github.com/cnpm/cnpm/issues/226]( https://zhuanlan.zhihu.com/p/22934066)

    至于为什么维护者有这么一篇文章[https://zhuanlan.zhihu.com/p/22934066]( https://zhuanlan.zhihu.com/p/22934066)
    cloudzqy
        2
    cloudzqy  
       2018-04-23 11:55:51 +08:00
    cnpm 和 npm 有很多不一样,这只是其中之一,还有很多坑。
    前端工具链已经够艰难,不要给自己添堵了,用回 npm 吧,速度慢换镜像就行了。
    noe132
        3
    noe132  
       2018-04-23 12:33:37 +08:00 via Android
    我以前用 cnpm 安装的依赖目录结构会导致 atom 循环读取内存泄漏,不知道修复了没有。。。
    BearD01001
        4
    BearD01001  
       2018-04-23 12:37:06 +08:00 via iPhone
    不推荐用 cnpm,坑多。设置一个 alias 用淘宝镜像吧,也很方便的。
    关于   ·   帮助文档   ·   博客   ·   nftychat   ·   API   ·   FAQ   ·   我们的愿景   ·   实用小工具   ·   1231 人在线   最高记录 5634   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 36ms · UTC 23:29 · PVG 07:29 · LAX 16:29 · JFK 19:29
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.