V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
iMboya
V2EX  ›  CentOS

rpm 更新软件 wkhtmltox 报错

  •  
  •   iMboya · 2015-03-16 10:53:46 +08:00 · 2725 次点击
    这是一个创建于 3316 天前的主题,其中的信息可能已经有所发展或是发生改变。
    [root@xxx/]# rpm -Uvh wkhtmltox-0.12.2.1_linux-centos6-amd64.rpm 
    error: Failed dependencies:
        xorg-x11-fonts-Type1 is needed by wkhtmltox-1:0.12.2.1-1.x86_64
        xorg-x11-fonts-75dpi is needed by wkhtmltox-1:0.12.2.1-1.x86_64
    
    [root@xxx/]# rpm -ivh wkhtmltox-0.12.2.1_linux-centos6-amd64.rpm 
    error: Failed dependencies:
        xorg-x11-fonts-Type1 is needed by wkhtmltox-1:0.12.2.1-1.x86_64
        xorg-x11-fonts-75dpi is needed by wkhtmltox-1:0.12.2.1-1.x86_64
    

    这算是个什么问题?
    升级和直接安装都提示这个依赖。
    囧的是依赖的又都是我想安装的版本……

    顺便问一下,哪位大神用过这个wkhtmltox(pdf/image),
    这东西的错误日志怎么看?
    我有些页面生成图片的时候在rendering的时候卡住,然后killed结束……
    没有任何错误信息。
    图片文件是个错误的文件,无法显示。
    问题是明明都是类似的页面,没有什么特别大的差别,大部分的页面都能生成,个别页面就会这样失败。
    github里也提问了,作者没回复,想升级看看,就遇到上面的报错了,求解……

    目前尚无回复
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   我们的愿景   ·   实用小工具   ·   2749 人在线   最高记录 6543   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 29ms · UTC 07:00 · PVG 15:00 · LAX 00:00 · JFK 03:00
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.