首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
V2EX  ›  Linux

编译 openssl 时的选项,精简那些比较合适 ?

  •  
  •   station · 8 天前 · 1199 次点击
    有些加密算法,未必用到的

    官方给出了部分,但有些选项已经弃用

    https://wiki.openssl.org/index.php/Compilation_and_Installation

    下面是我 github 扒到的

    11 回复  |  直到 2019-02-12 00:02:27 +08:00
        1
    no1xsyzy   8 天前
    所有用不到的
        2
    mikeguan   8 天前 via Android
    换系统的 openssl 应该算是比较大的动作了,被依赖太多。
    精简是为了嵌入式系统?那就安装官网给出的说明操作试试
        3
    wsy2220   8 天前
    编译时禁止不是个好办法, 运行时配置比较好
        4
    station   7 天前 via iPhone
    @mikeguan 编译路由器固件,原版的太旧了
        5
    station   7 天前 via iPhone
    @wsy2220 存储空间有限,能节省些是一些
        6
    mikeguan   7 天前 via Android
    @station 如果是 openwrt 的话 可以直接用官方 SDK 来进行编译
        7
    xratzh   7 天前 via Android
    的确有些固件的 openssl 太老,但固件本身有很优秀,没必要重新编译,最好的就是编译新的 openssl
        8
    msg7086   7 天前
    编译相同版本的 OpenSSL 的话,直接用原版的编译脚本对着新 OpenSSL 编译就行了吧。
    精简嘛……我觉得你可以一步一步来,先完整包编译通了,再逐渐缩减功能。
        9
    HaoLan   7 天前 via Android
    不用精简了,多麻烦。openssl 占不到很多空间
        10
    phrnet   7 天前
    不要精简 openssl 重新编译会想死人 重装系统的心都有

    过来人。。。
        11
    jim9606   7 天前
    我不知道你的 openssl 用在什么程序上。
    如果只用于 ssl 不需要兼容老版本的话可以关掉老版本和旧算法的支持(例如 TLS1.0/1.1,SRP,RC4,PSK,IDEA,NPN )和少用的功能(例如 DTLS )。
    但别的用途就不好说了(例如 transmission 需要 RC4 来实现协议加密)
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3952 人在线   最高记录 4385   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 16ms · UTC 07:46 · PVG 15:46 · LAX 23:46 · JFK 02:46
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1