V2EX 首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  Android

最低支持版本为 5.1 的 APP 有必要使用 V7 包和 V4 包吗

  •  
  •   Gehrman · 5 天前 · 674 次点击
    主要是 Activity 和 Fragment 有必要使用 support 包里的吗
    8 回复  |  直到 2018-01-11 16:37:53 +08:00
        1
    hackerwgf   5 天前
    要用,support 包其实就是 google 给开发者提供的热更新,只不过更新间隔比较长
        3
    yrom   5 天前
    如果要用 RecyclerView 之类的,还是要引入 support 的
        4
    Gehrman   5 天前
    了解,多谢大家
    话说 Style 使用 android:Theme.Material 究竟有没有意义,感觉跟 Theme.AppCompat 没什么区别
        5
    RikkaW   5 天前
    Fragment 还是有必要的
    appcompat 的话,如果不用依赖了 appcompat 的库就可以不用
        6
    RikkaW   5 天前
    @Gehrman 如果不想引入 appcompat 就直接用 android:Theme.Material (但是可能会被厂商改),用 AppCompatActivity (和其他的扯到的)就必须用 Theme.AppCompat

    没有区别是因为 AppCompat 本来就是把系统的东西完全复制成自己的一份,然后一些低版本就可以使用高版本才有的东西
        7
    Gehrman   5 天前
    @RikkaW 看了下 AppCompat 是包含了 Material 的元素的,谢谢
        8
    shiguiyou   5 天前
    要用的,你用系统的每个版本可能外观不一样,support 包是固定的,而且 support 包还会更新,系统的国内环境不会升级补丁啥的
    DigitalOcean
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   鸣谢   ·   693 人在线   最高记录 3541   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.0 · 39ms · UTC 18:56 · PVG 02:56 · LAX 10:56 · JFK 13:56
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1